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ABSTRACT: Introductory materials science and engineering
courses universally include the study of crystal structure and unit
cells, which are by their nature highly visual 3D concepts.
Traditionally, such topics are explored with 2D drawings or perhaps
a limited set of difficult-to-construct 3D models. The rise of 3D
printing, coupled with the wealth of freely available crystallographic
data online, offers an elegant solution to materials science
visualization problems. Here, we report a concise and up-to-date
method to easily and rapidly transform actual crystallography files to
3D models of diverse unit cells for use as instructional aids.
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Typical material science and engineering introductory
curriculum, as exemplified in the seminal Callister text,1

includes extended discussion of crystal structures. Such a class
in materials science is required as part of the general
engineering core courses in many engineering degrees, and
the topic is sometimes also included in advanced high school
chemistry, first year general chemistry at university, and upper-
division inorganic chemistry classes. A firm grasp of 3D crystal
structures is essential to understanding important analytical
techniques such as X-ray crystallography. The number of
degrees granted in materials science has been growing in recent
years,2 and there is active discussion about how it is crucial that
materials departments focus on education, including instruc-
tional creativity and charisma, to recruit bright students.3

3D printing is an emerging technology with applications that
span across many disciplines.4 Its use for creating educational
materials is not new, but such endeavors do tend to
underestimate the complexity of the task.5 There are a handful
of existing publications on how to 3D print molecules.6 Many
focus on either simple organic molecules or complex metal−
organic frameworks. Others are highly technical or, despite
being only a couple years old, already out of date in regards to
the rapidly upgrading software versions. This report is focused
on streamlining the process of 3D printing crystal structures so
that a novice instructor can handily print visually attractive
models of all seven crystal systems and even any crystalline

material registered on an open database or otherwise available
as a cif file.
The advantage of the method reported here is that it focuses

on unit cells discussed in materials science and engineering
courses, it uses real data in a streamlined manner, it is widely
accessible, and it results in visually attractive 3D models. Such
3D models are potentially useful for class discussions, but of
course their utility is limited by how well they are integrated
into the larger scope of the course by the instructor. 3D models
are perhaps most useful to students who are kinesthetic or
tactile learners, and such models could be used in conjunction
with virtual visualizations, drawings, and verbal descriptions, so
that students of all learning styles could have a comprehensive
understanding of unit cells in materials science and engineering.
The process reported here takes only a few short steps. A

material is first located within the Crystallography Open
Database,7 and the crystallographic data file (cif) is down-
loaded. The cif file is opened with VESTA,8 a free chemical
visualization software and, after a few quick manipulations, is
exported as an wrl file. The wrl file is then opened with Blender,
another free software package, and undergoes brief editing
before being exported as an stl file.9 This stl file, with perhaps
some scaffolding added, can then be fed directly to 3D printers
such as a MakerBot. The 3D crystal structures pictured in this
report were all printed on the Columbia University Science
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Library 3D MakerBot Replicator 2 printer, but may also be
outsourced to general 3D printer companies such as Shape-
Ways. Although a 3D printer such as the MakerBot 2 Replicator
is rather expensive, it is quite affordable to outsource the
printing of a few models to companies such as Shapeways. The
models presented here were printed using polylactic acid
(PLA) filament, which results in sturdy and appealing 3D unit
cells for crystallographic systems. Process steps are detailed
below.

■ PROCESS

Crystallography Open Database and Material Selection

The Crystallography Open Database (COD) is a great
resource.7 The COD data can be easily searched, perhaps by
element, knowing what material is desired to be modeled. A
search for Ce and O, for example, returns a few results (CeO2
and Ce2O3), with journal references for further details on the
entry. Clicking on CIF downloads the cif crystallography file for
the indicated entry. The COD boasts over 318 000 entries and
of course includes all materials that an introductory student
would encounter. Although the COD is the method preferred
here, other alternative databases are available.10

Vesta. Visualization for Electronic and Structural Analysis
(VESTA) is freely available software.8 It is useful for visualizing
cif files, as well as many other purposes. It was found to be
more intuitive and simple to use, for the purposes here, when
compared to Mercury,11 which is another software platform
widely cited in the molecular model 3D printing community.
Once the cif file is opened in VESTA (File → Open), the
default display is ball-and-stick with invisible bonds. To make
the bonds visible, bring up the bonds menu (Edit → Bonds).
On the bonds menu, click “New” to create a new set of bonds.
The unit cells usually look best with the boundary mode set to
not search beyond the boundary, and editing the minimum and
maximum bond length such that only neighboring pairs are
bonded. Once the appropriate bonds are created and
confirmed, the properties menu should be accessed (Properties
button under Style tab). To aid the stability of the printed
structure, atom and bond sizes should probably be increased.
Multiplying the atom sizes by 1.5 and tripling the bond cylinder
radius was a successful combination in many cases. This can be
done under the atoms tab of the properties menu and the
bonds tab, respectively. Finally, the file can be exported (File→
Export) as a wrl file.
Blender. Blender is a powerful graphic visualization software

available for free download.9 Its ability to visualize molecules is
helped by the free plugin ePMV (embedded Python Molecular
Viewer12). The default structures that appear when opening
Blender can be deleted by right-clicking on them, hitting delete,
and confirming. The wrls can be imported (File → Import →
wrl), and then the ePMV button at the top right of the window
should be selected. The whole molecule should be selected
(Select → Select All), and then converted to a print object
(Object → Convert To → Mesh from Curve/Meta/Surf/
Text). Now the file is ready to be exported as an stl (File →
Export → stl). This stl file can be uploaded onto sites such as
Will It 3D Print13 to confirm its compatibility with the 3D
printing process, which requires 3D model files to have
particular characteristics in order for the printer’s software to
properly interpret them as solid objects.
Further File Edits and Printing Process. The analysis

carried out by Will It 3D Print13 is helpful but not always

sufficient to ensure a quality print. There are many variables
affecting the final product, including the quality and condition
of the supplied plastic material, the particular characteristics of
the specific printer being used, and occasionally even the
ambient temperature. It is likely that the successful production
of a finished model will require some iterations of design
modification and printer settings adjustments.
The simplest next step is to open the stl file in the Makerbot

Desktop software that will prepare the file for printing. With
the use of the Change Position dialogue box, the model should
ideally be placed at the center of the platform, by clicking both
the On Platform and the Center buttons. The Change Rotation
dialogue box can be used to change the orientation of the
model relative to the printing surface; this can be useful in
terms of minimizing the surfaces that will require a support
structure to be printed beneath them, thereby using less plastic
in the process. Under Settings, standard quality options (0.2
mm layer height, 10% infill, 2 shells, 200 °C extrusion
temperature when using PLA) are a good starting point,
making sure to check the Raft and Supports boxes. A raft is a
flat layer of plastic that is deposited on the platform to serve as
an attachment point to the printed model; the supports are
extra plastic parts printed to brace parts of the model that
would otherwise be extruded into midair. The Makerbot
Desktop version of supports are thin sheets of plastic that can
be torn off after printing by hand or using tools such as pliers.
Supports are particularly important since the ball-and-stick
models will have overhanging sections that cannot be printed
successfully without an underlying structure. Once the settings
are saved, clicking the Export Print File button will produce a
preview of the print process, and subsequently, a saved file with
printer instructions (in the case of the MakerBot, a file with the
extension X3G). This file can then be sent to the printer either
through the MakerBot software itself, if the computer is
connected to the printer, or it can be saved to a SD card to be
inserted into the printer and selected using the MakerBot’s
built-in menu.

■ RESULTS

3D Printed Unit Cells

Shown in Figure 1 are examples of 3D printed unit cells.

Figure 1. Unit cells, 3-D printed using the process described, of (from
top left clockwise): perovskite, rock salt, tetragonal spinel, fluorite,
corundum, and space-filling tetragonal spinel featuring dual atom
colors. Unit cells pictured here are about 3 in. tall.
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Variations

The process described here is of course only a streamlined and
quick guide for beginners. This process can be readily adapted
to suit various related purposes, including printing with
instruments other than the MakerBot, or using different
software to generate the necessary final product. For example,
a program called Meshmixer14 can be used to generate supports
that are different from the ones automatically generated by the
MakerBot Desktop software. Whereas the MakerBot supports
are thin strips of plastic, MeshMixer creates tubular supports
with very small attachment points to the model itself, possibly
resulting in a cleaner final product once the supports are
removed. Meshmixer generates customizable supports and
allows for manually placing and removing supports from
different parts of the model; experience may suggest that a
given section needs more support than calculated by the
software. Once the model is finished, it can be exported once
again in stl format, to be then opened with MakerBot Desktop
for the final preparation.
With the method described here, the easiest way to

distinguish between different atom types is by atomic size.
The VESTA program easily allows switching between atomic
radius or ionic radius or whatever custom radius the user
chooses. Other options include painting the atoms different
colors by hand after the printing process. 3D printing in
multiple colors is challenging because in many cases two
different files must be created (one for each color). The space-
filling tetragonal spinel featuring dual atom colors pictured in
Figure 1 was achieved by alternatively setting atoms of one type
to a radius of zero and exporting individually; it was then
manufactured using a printer equipped with dual extruders, one
for each color. Many more advanced techniques are possible
once a foundational familiarity (as described in this report) has
been achieved.
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